«

»

2月 20

WordPress のアップグレードとPHPバージョンアップ(centOS 5.6)

久しぶりにサーバーのバージョンアップを行いました。

現在 wordpress Version 3.1.2

php      Version 5.1.6

となってました。

これを

wordpress Version_3.3.1(平成24年2月20日現在)

それにともないphpのバージョンは、PHP 5.2.4 以降を必要とするらしいのですが version 5.3.3が新しいらしいのでこれをインストールしてみました。

最初にアパッチ(webサーバ)の停止

[root~]# /etc/rc.d/init.d/httpd stop

まずphp の古いバージョンを削除しないといけないらしいので

[root~]# yum remove php php-*
Loaded plugins: downloadonly, fastestmirror, priorities
Setting up Remove Process
Resolving Dependencies
–> Running transaction check
—> Package php.i386 0:5.1.6-27.el5_5.3 set to be erased
—> Package php-cli.i386 0:5.1.6-27.el5_5.3 set to be erased
—> Package php-common.i386 0:5.1.6-27.el5_5.3 set to be erased
—> Package php-gd.i386 0:5.1.6-27.el5_5.3 set to be erased
—> Package php-mbstring.i386 0:5.1.6-27.el5_5.3 set to be erased
–> Processing Dependency: php-mbstring >= 4.1.0 for package: phpmyadmin
—> Package php-mcrypt.i386 0:5.1.6-15.el5.centos.1 set to be erased
—> Package php-mysql.i386 0:5.1.6-27.el5_5.3 set to be erased
—> Package php-pdo.i386 0:5.1.6-27.el5_5.3 set to be erased
–> Running transaction check
—> Package phpmyadmin.noarch 0:2.11.11.3-1.el5.rf set to be erased
–> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================
Package Arch Version Repository Size
==========================================================================================
Removing:
php i386 5.1.6-27.el5_5.3 installed 5.9 M
php-cli i386 5.1.6-27.el5_5.3 installed 5.2 M
php-common i386 5.1.6-27.el5_5.3 installed 393 k
php-gd i386 5.1.6-27.el5_5.3 installed 327 k
php-mbstring i386 5.1.6-27.el5_5.3 installed 1.6 M
php-mcrypt i386 5.1.6-15.el5.centos.1 installed 32 k
php-mysql i386 5.1.6-27.el5_5.3 installed 175 k
php-pdo i386 5.1.6-27.el5_5.3 installed 100 k
Removing for dependencies:
phpmyadmin noarch 2.11.11.3-1.el5.rf installed 13 M

Transaction Summary
==========================================================================================
Remove 9 Package(s)
Reinstall 0 Package(s)
Downgrade 0 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : php-mbstring 1/9
Erasing : php-pdo 2/9
Erasing : php-gd 3/9
Erasing : php-common 4/9
警告: /etc/php.ini は /etc/php.ini.rpmsave として保存されました。
Erasing : php-cli 5/9
Erasing : php-mysql 6/9
Erasing : php 7/9
Erasing : php-mcrypt 8/9
Erasing : phpmyadmin 9/9
警告: /etc/httpd/conf.d/phpmyadmin.conf は /etc/httpd/conf.d/phpmyadmin.conf.rpmsave とし て保存されました。

Removed:
php.i386 0:5.1.6-27.el5_5.3 php-cli.i386 0:5.1.6-27.el5_5.3
php-common.i386 0:5.1.6-27.el5_5.3 php-gd.i386 0:5.1.6-27.el5_5.3
php-mbstring.i386 0:5.1.6-27.el5_5.3 php-mcrypt.i386 0:5.1.6-15.el5.centos.1
php-mysql.i386 0:5.1.6-27.el5_5.3 php-pdo.i386 0:5.1.6-27.el5_5.3

Dependency Removed:
phpmyadmin.noarch 0:2.11.11.3-1.el5.rf

Complete!

これでとりあえず削除できました。

次にphpの5.3.3バージョンをインストール

[root~]# yum install php53 php53-mbstring php53-mysql
で最初やったんですがwordpressが上手くたちあがらなったので再度実行(今度は、フルパッケージで)
[root~]# yum remove php53*
として再度
[root~]# yum install php53*
Loaded plugins: downloadonly, fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: ftp.nara.wide.ad.jp
* extras: ftp.nara.wide.ad.jp
* rpmforge: ftp-stud.fht-esslingen.de
* updates: ftp.nara.wide.ad.jp
116 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package php53.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-bcmath.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-cli.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-common.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-dba.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-devel.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-gd.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-imap.i386 0:5.3.3-1.el5_7.6 set to be updated
–> Processing Dependency: libc-client.so.1 for package: php53-imap
—> Package php53-intl.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-ldap.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-mbstring.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-mysql.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-odbc.i386 0:5.3.3-1.el5_7.6 set to be updated
–> Processing Dependency: libodbc.so.1 for package: php53-odbc
—> Package php53-pdo.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-pgsql.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-process.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-pspell.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-snmp.i386 0:5.3.3-1.el5_7.6 set to be updated
–> Processing Dependency: libnetsnmp.so.10 for package: php53-snmp
–> Processing Dependency: net-snmp for package: php53-snmp
—> Package php53-soap.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-xml.i386 0:5.3.3-1.el5_7.6 set to be updated
—> Package php53-xmlrpc.i386 0:5.3.3-1.el5_7.6 set to be updated
–> Running transaction check
—> Package libc-client.i386 0:2004g-2.2.1 set to be updated
—> Package net-snmp.i386 1:5.3.2.2-14.el5_7.1 set to be updated
–> Processing Dependency: libsensors.so.3 for package: net-snmp
—> Package net-snmp-libs.i386 1:5.3.2.2-14.el5_7.1 set to be updated
—> Package unixODBC.i386 0:2.2.11-7.1 set to be updated
–> Running transaction check
—> Package lm_sensors.i386 0:2.10.7-9.el5 set to be updated
–> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================
Package Arch Version Repository Size
==========================================================================================
Installing:
php53 i386 5.3.3-1.el5_7.6 updates 1.3 M
php53-bcmath i386 5.3.3-1.el5_7.6 updates 42 k
php53-cli i386 5.3.3-1.el5_7.6 updates 2.5 M
php53-common i386 5.3.3-1.el5_7.6 updates 604 k
php53-dba i386 5.3.3-1.el5_7.6 updates 39 k
php53-devel i386 5.3.3-1.el5_7.6 updates 591 k
php53-gd i386 5.3.3-1.el5_7.6 updates 108 k
php53-imap i386 5.3.3-1.el5_7.6 updates 50 k
php53-intl i386 5.3.3-1.el5_7.6 updates 73 k
php53-ldap i386 5.3.3-1.el5_7.6 updates 36 k
php53-mbstring i386 5.3.3-1.el5_7.6 updates 1.2 M
php53-mysql i386 5.3.3-1.el5_7.6 updates 87 k
php53-odbc i386 5.3.3-1.el5_7.6 updates 51 k
php53-pdo i386 5.3.3-1.el5_7.6 updates 66 k
php53-pgsql i386 5.3.3-1.el5_7.6 updates 73 k
php53-process i386 5.3.3-1.el5_7.6 updates 37 k
php53-pspell i386 5.3.3-1.el5_7.6 updates 26 k
php53-snmp i386 5.3.3-1.el5_7.6 updates 29 k
php53-soap i386 5.3.3-1.el5_7.6 updates 146 k
php53-xml i386 5.3.3-1.el5_7.6 updates 112 k
php53-xmlrpc i386 5.3.3-1.el5_7.6 updates 52 k
Installing for dependencies:
libc-client i386 2004g-2.2.1 base 516 k
lm_sensors i386 2.10.7-9.el5 base 511 k
net-snmp i386 1:5.3.2.2-14.el5_7.1 updates 702 k
net-snmp-libs i386 1:5.3.2.2-14.el5_7.1 updates 1.3 M
unixODBC i386 2.2.11-7.1 base 832 k

Transaction Summary
==========================================================================================
Install 26 Package(s)
Upgrade 0 Package(s)

Total download size: 11 M
Is this ok [y/N]: y
Downloading Packages:
(1/26): php53-pspell-5.3.3-1.el5_7.6.i386.rpm | 26 kB 00:00
(2/26): php53-snmp-5.3.3-1.el5_7.6.i386.rpm | 29 kB 00:00
(3/26): php53-ldap-5.3.3-1.el5_7.6.i386.rpm | 36 kB 00:00
(4/26): php53-process-5.3.3-1.el5_7.6.i386.rpm | 37 kB 00:00
(5/26): php53-dba-5.3.3-1.el5_7.6.i386.rpm | 39 kB 00:00
(6/26): php53-bcmath-5.3.3-1.el5_7.6.i386.rpm | 42 kB 00:00
(7/26): php53-imap-5.3.3-1.el5_7.6.i386.rpm | 50 kB 00:00
(8/26): php53-odbc-5.3.3-1.el5_7.6.i386.rpm | 51 kB 00:00
(9/26): php53-xmlrpc-5.3.3-1.el5_7.6.i386.rpm | 52 kB 00:00
(10/26): php53-pdo-5.3.3-1.el5_7.6.i386.rpm | 66 kB 00:00
(11/26): php53-pgsql-5.3.3-1.el5_7.6.i386.rpm | 73 kB 00:00
(12/26): php53-intl-5.3.3-1.el5_7.6.i386.rpm | 73 kB 00:00
(13/26): php53-mysql-5.3.3-1.el5_7.6.i386.rpm | 87 kB 00:00
(14/26): php53-gd-5.3.3-1.el5_7.6.i386.rpm | 108 kB 00:00
(15/26): php53-xml-5.3.3-1.el5_7.6.i386.rpm | 112 kB 00:00
(16/26): php53-soap-5.3.3-1.el5_7.6.i386.rpm | 146 kB 00:00
(17/26): lm_sensors-2.10.7-9.el5.i386.rpm | 511 kB 00:01
(18/26): libc-client-2004g-2.2.1.i386.rpm | 516 kB 00:00
(19/26): php53-devel-5.3.3-1.el5_7.6.i386.rpm | 591 kB 00:01
(20/26): php53-common-5.3.3-1.el5_7.6.i386.rpm | 604 kB 00:01
(21/26): net-snmp-5.3.2.2-14.el5_7.1.i386.rpm | 702 kB 00:01
(22/26): unixODBC-2.2.11-7.1.i386.rpm | 832 kB 00:01
(23/26): php53-mbstring-5.3.3-1.el5_7.6.i386.rpm | 1.2 MB 00:02
(24/26): php53-5.3.3-1.el5_7.6.i386.rpm | 1.3 MB 00:02
(25/26): net-snmp-libs-5.3.2.2-14.el5_7.1.i386.rpm | 1.3 MB 00:02
(26/26): php53-cli-5.3.3-1.el5_7.6.i386.rpm | 2.5 MB 00:04
——————————————————————————————
Total 442 kB/s | 11 MB 00:25
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : php53-common 1/26
Installing : php53-pdo 2/26
Installing : net-snmp-libs 3/26
Installing : php53-cli 4/26
Installing : php53 5/26
Installing : libc-client 6/26
Installing : unixODBC 7/26
Installing : lm_sensors 8/26
Installing : net-snmp 9/26
Installing : php53-xml 10/26
Installing : php53-pspell 11/26
Installing : php53-ldap 12/26
Installing : php53-mbstring 13/26
Installing : php53-odbc 14/26
Installing : php53-gd 15/26
Installing : php53-imap 16/26
Installing : php53-intl 17/26
Installing : php53-snmp 18/26
Installing : php53-devel 19/26
Installing : php53-pgsql 20/26
Installing : php53-mysql 21/26
Installing : php53-xmlrpc 22/26
Installing : php53-bcmath 23/26
Installing : php53-dba 24/26
Installing : php53-soap 25/26
Installing : php53-process 26/26

Installed:
php53.i386 0:5.3.3-1.el5_7.6 php53-bcmath.i386 0:5.3.3-1.el5_7.6
php53-cli.i386 0:5.3.3-1.el5_7.6 php53-common.i386 0:5.3.3-1.el5_7.6
php53-dba.i386 0:5.3.3-1.el5_7.6 php53-devel.i386 0:5.3.3-1.el5_7.6
php53-gd.i386 0:5.3.3-1.el5_7.6 php53-imap.i386 0:5.3.3-1.el5_7.6
php53-intl.i386 0:5.3.3-1.el5_7.6 php53-ldap.i386 0:5.3.3-1.el5_7.6
php53-mbstring.i386 0:5.3.3-1.el5_7.6 php53-mysql.i386 0:5.3.3-1.el5_7.6
php53-odbc.i386 0:5.3.3-1.el5_7.6 php53-pdo.i386 0:5.3.3-1.el5_7.6
php53-pgsql.i386 0:5.3.3-1.el5_7.6 php53-process.i386 0:5.3.3-1.el5_7.6
php53-pspell.i386 0:5.3.3-1.el5_7.6 php53-snmp.i386 0:5.3.3-1.el5_7.6
php53-soap.i386 0:5.3.3-1.el5_7.6 php53-xml.i386 0:5.3.3-1.el5_7.6
php53-xmlrpc.i386 0:5.3.3-1.el5_7.6

Dependency Installed:
libc-client.i386 0:2004g-2.2.1 lm_sensors.i386 0:2.10.7-9.el5
net-snmp.i386 1:5.3.2.2-14.el5_7.1 net-snmp-libs.i386 1:5.3.2.2-14.el5_7.1
unixODBC.i386 0:2.2.11-7.1

Complete!

として今度は、php533系のすべてのパッケージをインストールしました。
その後、上手くwordpress画面が表示されないのでwordpress3.31を新規でインストールしました。

[root~]# wget http://ja.wordpress.org/wordpress-3.3.1-ja.zip

[root~]# unzip wordpress-3.31-ja.zip

今あるwordpressを名前を変更して退避
[root~]# mv /var/www/wordpress /var/www/wordpress_old

新規のヴァージョンを移動
[root~]# mv wordpress /var/www/

[root~]# chown -R apache:apache /var/www/wordpress/

細部今まで使っていた設定ファイルやテーマ、プラグイン、Uploadファイル(写真)などをoldからコピー
(そのほか個人的にwordpressをいじっている人はその部分もコピーしてください)

設定ファイルのコピー
[root~]# /var/www/wordpress_old/wp-config.php /var/www/wordpress/wp-config.php
使用しているテーマのコピー
[root~]# cp /var/www/wordpress_old/wp-content/themes/テーマファイル名 cp /var/www/wordpress/wp-content/themes/
使用しているプラグインのコピー
[root~]# cp /var/www/wordpress_old/wp-content/plugins/プラグインファイル名 /var/www/wordpress/wp-content/plugins/
UPした写真のディレクトリのコピー(データ量により少し時間がかかる)
[root~]# cp[root~]# cp /var/www/wordpress_old/wp-content/uploads /var/www/wordpress_old/wp-content/

大体これでwordpressおよびPHPのバージョンアップができました。

[root~]# php -v
PHP 5.3.3 (cli) (built: Feb 2 2012 18:29:23)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

最後にアパッチ(webサーバ)の起動
[root~]# /etc/rc.d/init.d/httpd start

けれどよく調べて見るとwordpressの新規インストールじゃなく管理画面からバージョンアップでやれればここまで面倒くさくなくできそうです。

私の場合上記のようにwordpressのadmin画面(管理画面)が表示できなくなったので直接サーバー上に最新のwordpressをダウンロードしてやりましたが・・・

原因としてプラグインのsmart-update-pingerが悪さをしていたためみたいです。
このプラグインがある場合削除してからphpのバージョンアップを行うと上手くいきそうです。
またwordpressが新しくなったときにプラグインが対応していない場合、上手く表示できない場合があるので一度全部解除しておくほうがいいかもしれません。
(私の場合、トップページの上部のほうにsmart-update-pingerのphp言語がそのまま表示されていました。)

しかもPHPのパッケージも必要なものだけインストールすればスマートなんですが、必要なものが何かわからない人は、私と同じようにすぺてのパッケージをインストールすれば簡単にできそうです(^^;

次回またPHPのバージョンアップがあったときの備忘録的に書いておきます。

それにしてもインフルエンザになったら良い事ないので皆さんも気をつけましょう。職場や家族にも迷惑かけまくりだし・・・

いろんな意味で辛い1週間になりそうです・・・・・(TmT)ウゥゥ・・・
応援をお願いします。


にほんブログ村 観賞魚ブログ シュリンプ(エビ)へ
にほんブログ村

にほんブログ村 写真ブログ デジタル一眼レフカメラへ
にほんブログ村

ブログランキング・にほんブログ村へ
にほんブログ村