«

»

12月 13

phpを最新バージョンにアップデート その2

続きです。なかなか最新版にアップデートするのも面倒くさいですね。
いろいろとバージョンアップされている方は、一度php関連をすべてremove&installしている人が大半ですが、なんとなくいやなのでPHP関連をすべてupdateしようと思います。

[root@www16071ue ~]# yum update php.x86_64 --disablerepo=base,extras,updates --enablerepo=remi-php55
読み込んだプラグイン:downloadonly, fastestmirror, priorities, security
更新処理の設定をしています
Loading mirror speeds from cached hostfile
 * remi-php55: remi.kazukioishi.net
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: php-common(x86-64) = 5.5.19-2.el6.remi のパッケージ: php-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: php-cli(x86-64) = 5.5.19-2.el6.remi のパッケージ: php-5.5.19-2.el6.remi.x86_64
--> トランザクションの確認を実行しています。
---> Package php-cli.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-cli.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-40.el6_6 will be 更新
--> 依存性の処理をしています: php-api = 20090626 のパッケージ: php-mcrypt-5.3.3-1.el6.rf.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-40.el6_6 のパッケージ: php-pdo-5.3.3-40.el6_6.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-40.el6_6 のパッケージ: php-mysql-5.3.3-40.el6_6.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-40.el6_6 のパッケージ: php-mbstring-5.3.3-40.el6_6.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-40.el6_6 のパッケージ: php-gd-5.3.3-40.el6_6.x86_64
---> Package php-common.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: php-pecl-zip(x86-64) のパッケージ: php-common-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: php-pecl-jsonc(x86-64) のパッケージ: php-common-5.5.19-2.el6.remi.x86_64
--> トランザクションの確認を実行しています。
---> Package php-gd.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-gd.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libvpx.so.1()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libt1.so.5()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-mbstring.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6.rf will be 更新
---> Package php-mcrypt.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.3.3-40.el6_6 will be 不要
---> Package php-mysqlnd.x86_64 0:5.5.19-2.el6.remi will be obsoleting
---> Package php-pdo.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-pdo.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-pecl-jsonc.x86_64 0:1.3.6-1.el6.remi.5.5.1 will be インストール
--> 依存性の処理をしています: /usr/bin/pecl のパッケージ: php-pecl-jsonc-1.3.6-1.el6.remi.5.5.1.x86_64
--> 依存性の処理をしています: /usr/bin/pecl のパッケージ: php-pecl-jsonc-1.3.6-1.el6.remi.5.5.1.x86_64
---> Package php-pecl-zip.x86_64 0:1.12.4-1.el6.remi.5.5 will be インストール
--> トランザクションの確認を実行しています。
---> Package php-gd.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libvpx.so.1()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libt1.so.5()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
---> Package php-pear.noarch 1:1.9.4-20.el6.remi will be インストール
--> 依存性の処理をしています: php-xml のパッケージ: 1:php-pear-1.9.4-20.el6.remi.noarch
--> 依存性の処理をしています: php-posix のパッケージ: 1:php-pear-1.9.4-20.el6.remi.noarch
--> トランザクションの確認を実行しています。
---> Package php-gd.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libvpx.so.1()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libt1.so.5()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
---> Package php-process.x86_64 0:5.5.19-2.el6.remi will be インストール
---> Package php-xml.x86_64 0:5.5.19-2.el6.remi will be インストール
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.24)(64bit) のパッケージ: php-xml-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.22)(64bit) のパッケージ: php-xml-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.18)(64bit) のパッケージ: php-xml-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.13)(64bit) のパッケージ: php-xml-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.11)(64bit) のパッケージ: php-xml-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libxslt.so.1()(64bit) のパッケージ: php-xml-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libexslt.so.0()(64bit) のパッケージ: php-xml-5.5.19-2.el6.remi.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: php-xml-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libxslt.so.1()(64bit)
エラー: パッケージ: php-xml-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libxslt.so.1(LIBXML2_1.0.24)(64bit)
エラー: パッケージ: php-xml-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libxslt.so.1(LIBXML2_1.0.22)(64bit)
エラー: パッケージ: php-xml-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libexslt.so.0()(64bit)
エラー: パッケージ: php-gd-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: gd-last(x86-64) >= 2.1.0-3
エラー: パッケージ: php-gd-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libgd.so.3()(64bit)
エラー: パッケージ: php-xml-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libxslt.so.1(LIBXML2_1.0.18)(64bit)
エラー: パッケージ: php-gd-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libt1.so.5()(64bit)
エラー: パッケージ: php-xml-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libxslt.so.1(LIBXML2_1.0.13)(64bit)
エラー: パッケージ: php-gd-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libvpx.so.1()(64bit)
エラー: パッケージ: php-xml-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libxslt.so.1(LIBXML2_1.0.11)(64bit)
 問題を回避するために --skip-broken を用いることができません
 これらを試行できます: rpm -Va --nofiles --nodigest

これを見ると確かに上記のリストのものもバージョンアップしないといけないというエラーがでてますね。
抜粋すると以下のとおり
—> Package php.x86_64 0:5.5.19-2.el6.remi will be an update
—> Package php-cli.x86_64 0:5.5.19-2.el6.remi will be an update
—> Package php-common.x86_64 0:5.5.19-2.el6.remi will be an update
—> Package php-gd.x86_64 0:5.5.19-2.el6.remi will be an update
—> Package php-mbstring.x86_64 0:5.5.19-2.el6.remi will be an update
—> Package php-mcrypt.x86_64 0:5.5.19-2.el6.remi will be an update
—> Package php-mysql.x86_64 0:5.3.3-40.el6_6 will be 不要
—> Package php-mysqlnd.x86_64 0:5.5.19-2.el6.remi will be obsoleting
—> Package php-pdo.x86_64 0:5.5.19-2.el6.remi will be an update
—> Package php-pecl-jsonc.x86_64 0:1.3.6-1.el6.remi.5.5.1 will be インストール
—> Package php-pecl-zip.x86_64 0:1.12.4-1.el6.remi.5.5 will be インストール
—> Package php-pear.noarch 1:1.9.4-20.el6.remi will be インストール
—> Package php-process.x86_64 0:5.5.19-2.el6.remi will be インストール
—> Package php-xml.x86_64 0:5.5.19-2.el6.remi will be インストール

php-mysqlnd.x86_64を新しくインストールする代りに旧式扱いになっているパッケージ(php-mysql.x86_64)は削除する必要があるようです。(yum upgradeでphp-mysql.x86_64を削除する必要がある?)
そのほかは、UPDATEと新たにinstallが必要とのこと。

updateするものだけを指定してyum updateしましたがやはりインストールするものが必要とエラーが返されました。
では、先にインストールが必要といわれている5個をyum install —-disablerepo=base,extras,updates –enablerepo=remi-php55 phppecl….としましたが同じようにエラーが返されました。

では、通常のリポジトリでまず
php-pecl-jsonc.x86_64
php-pecl-zip.x86_64
php-pear.noarch
php-process.x86_64
php-xml.x86_64
をインストールするようにしてそのあとすべてをアップデートするようにしたら上手くいくかもということでやってみました。

[root@local ~]# yum install php-pecl-jsonc php-pecl-zip php-process php-xml
読み込んだプラグイン:downloadonly, fastestmirror, priorities, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * extras: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
パッケージ php-pecl-jsonc は利用できません。
パッケージ php-common-5.3.3-40.el6_6.x86_64 はインストール済みか最新バージョンです
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php-process.x86_64 0:5.3.3-40.el6_6 will be インストール
---> Package php-xml.x86_64 0:5.3.3-40.el6_6 will be インストール
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.24)(64bit) のパッケージ
: php-xml-5.3.3-40.el6_6.x86_64
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.22)(64bit) のパッケージ
: php-xml-5.3.3-40.el6_6.x86_64
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.18)(64bit) のパッケージ
: php-xml-5.3.3-40.el6_6.x86_64
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.13)(64bit) のパッケージ
: php-xml-5.3.3-40.el6_6.x86_64
--> 依存性の処理をしています: libxslt.so.1(LIBXML2_1.0.11)(64bit) のパッケージ
: php-xml-5.3.3-40.el6_6.x86_64
--> 依存性の処理をしています: libxslt.so.1()(64bit) のパッケージ
: php-xml-5.3.3-40.el6_6.x86_64
--> 依存性の処理をしています: libexslt.so.0()(64bit) のパッケージ
: php-xml-5.3.3-40.el6_6.x86_64
--> トランザクションの確認を実行しています。
---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be インストール
--> 依存性解決を終了しました。

依存性を解決しました

======================================================================================
 パッケージ      アーキテクチャ     バージョン     リポジトリー          容量
======================================================================================
インストールしています:
 php-process     x86_64           5.3.3-40.el6_6   updates               42 k
 php-xml         x86_64           5.3.3-40.el6_6   updates              106 k
依存性関連でのインストールをします。:
 libxslt         x86_64           1.1.26-2.el6_3.1 base                 452 k

トランザクションの要約
======================================================================================
インストール         3 パッケージ

総ダウンロード容量: 600 k
インストール済み容量: 2.5 M
これでいいですか? [y/N]y
パッケージをダウンロードしています:
(1/3): libxslt-1.1.26-2.el6_3.1.x86_64.rpm       | 452 kB     00:00
(2/3): php-process-5.3.3-40.el6_6.x86_64.rpm     |  42 kB     00:00
(3/3): php-xml-5.3.3-40.el6_6.x86_64.rpm         | 106 kB     00:00
---------------------------------------------------------------------------------------
合計                                    3.6 MB/s | 600 kB     00:00
rpm_check_debug を実行しています
トランザクションのテストを実行しています
トランザクションのテストを成功しました
トランザクションを実行しています
  インストールしています  : libxslt-1.1.26-2.el6_3.1.x86_64   1/3
  インストールしています  : php-xml-5.3.3-40.el6_6.x86_64     2/3
  インストールしています  : php-process-5.3.3-40.el6_6.x86_64 3/3
  Verifying               : php-xml-5.3.3-40.el6_6.x86_64     1/3
  Verifying               : libxslt-1.1.26-2.el6_3.1.x86_64   2/3
  Verifying               : php-process-5.3.3-40.el6_6.x86_64 3/3
インストール:
  php-process.x86_64 0:5.3.3-40.el6_6
  php-xml.x86_64 0:5.3.3-40.el6_6
依存性関連をインストールしました:
  libxslt.x86_64 0:1.1.26-2.el6_3.1
完了しました!

どうにかインストールは、完了したようなのでもう一度試してみます。

[root@www16071ue ~]# yum update php php-cli php-gd php-pdo php-mbstring php-mysql php-mcrypt php-common php-process php-xml  --disablerepo=base,extras,updates --enablerepo=remi-php55
読み込んだプラグイン:downloadonly, fastestmirror, priorities, security
更新処理の設定をしています
Loading mirror speeds from cached hostfile
 * remi-php55: remi.kazukioishi.net
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-cli.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-cli.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-common.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: php-pecl-zip(x86-64) のパッケージ: php-common-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: php-pecl-jsonc(x86-64) のパッケージ: php-common-5.5.19-2.el6.remi.x86_64
---> Package php-gd.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-gd.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libvpx.so.1()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libt1.so.5()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ: php-gd-5.5.19-2.el6.remi.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-mbstring.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6.rf will be 更新
---> Package php-mcrypt.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.3.3-40.el6_6 will be 不要
---> Package php-mysqlnd.x86_64 0:5.5.19-2.el6.remi will be obsoleting
---> Package php-pdo.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-pdo.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-process.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-process.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-xml.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-xml.x86_64 0:5.5.19-2.el6.remi will be an update
--> トランザクションの確認を実行しています。
---> Package php-gd.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ
: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libvpx.so.1()(64bit) のパッケージ
: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libt1.so.5()(64bit) のパッケージ
: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ
: php-gd-5.5.19-2.el6.remi.x86_64
---> Package php-pecl-jsonc.x86_64 0:1.3.6-1.el6.remi.5.5.1 will be インストール
--> 依存性の処理をしています: /usr/bin/pecl のパッケージ
: php-pecl-jsonc-1.3.6-1.el6.remi.5.5.1.x86_64
--> 依存性の処理をしています: /usr/bin/pecl のパッケージ
: php-pecl-jsonc-1.3.6-1.el6.remi.5.5.1.x86_64
---> Package php-pecl-zip.x86_64 0:1.12.4-1.el6.remi.5.5 will be インストール
--> トランザクションの確認を実行しています。
---> Package php-gd.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ
: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libvpx.so.1()(64bit) のパッケージ
: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libt1.so.5()(64bit) のパッケージ
: php-gd-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ
: php-gd-5.5.19-2.el6.remi.x86_64
---> Package php-pear.noarch 1:1.9.4-20.el6.remi will be インストール
--> 依存性解決を終了しました。
エラー: パッケージ: php-gd-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libt1.so.5()(64bit)
エラー: パッケージ: php-gd-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libvpx.so.1()(64bit)
エラー: パッケージ: php-gd-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: gd-last(x86-64) >= 2.1.0-3
エラー: パッケージ: php-gd-5.5.19-2.el6.remi.x86_64 (remi-php55)
             要求: libgd.so.3()(64bit)
 問題を回避するために --skip-broken を用いることができません
 これらを試行できます: rpm -Va --nofiles --nodigest

エラーがでてやっぱりだめなようです。
では、最後にエラーになるパッケージをremoveしてみます。php-gd-5.5.19-2.el6.remi.x86_64

[root@www16071ue ~]# yum remove php-gd
読み込んだプラグイン:downloadonly, fastestmirror, priorities, security
削除処理の設定をしています
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php-gd.x86_64 0:5.3.3-40.el6_6 will be 削除
--> 依存性解決を終了しました。

依存性を解決しました

=======================================================================================
 パッケージ       アーキテクチャ     バージョン      リポジトリー          容量
========================================================================================
削除:
 php-gd           x86_64       5.3.3-40.el6_6           @updates         324 k

トランザクションの要約
========================================================================================
削除                 1 パッケージ

インストール済み容量: 324 k
これでいいですか? [y/N]y
パッケージをダウンロードしています:
rpm_check_debug を実行しています
トランザクションのテストを実行しています
トランザクションのテストを成功しました
トランザクションを実行しています
  削除中                  : php-gd-5.3.3-40.el6_6.x86_64            1/1
  Verifying               : php-gd-5.3.3-40.el6_6.x86_64            1/1

削除しました       :  php-gd.x86_64 0:5.3.3-40.el6_6
完了しました!

なんだかあっさりremoveが完了しましたので、もう一度すべてをアップデートしてみます。

[root@local ~]# yum update php php-cli php-gd php-pdo php-mbstring php-mysql php-mcrypt php-common php-process php-xml  --disablerepo=base,extras,updates --enablerepo=remi-php55
読み込んだプラグイン:downloadonly, fastestmirror, priorities, security
更新処理の設定をしています
Loading mirror speeds from cached hostfile
 * remi-php55: remi.kazukioishi.net
パッケージ php-gd は利用できますが、インストールしませんでした。
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-cli.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-cli.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-common.x86_64 0:5.5.19-2.el6.remi will be an update
--> 依存性の処理をしています: php-pecl-zip(x86-64) のパッケージ
: php-common-5.5.19-2.el6.remi.x86_64
--> 依存性の処理をしています: php-pecl-jsonc(x86-64) のパッケージ
: php-common-5.5.19-2.el6.remi.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-mbstring.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6.rf will be 更新
---> Package php-mcrypt.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.3.3-40.el6_6 will be 不要
---> Package php-mysqlnd.x86_64 0:5.5.19-2.el6.remi will be obsoleting
---> Package php-pdo.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-pdo.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-process.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-process.x86_64 0:5.5.19-2.el6.remi will be an update
---> Package php-xml.x86_64 0:5.3.3-40.el6_6 will be 更新
---> Package php-xml.x86_64 0:5.5.19-2.el6.remi will be an update
--> トランザクションの確認を実行しています。
---> Package php-pecl-jsonc.x86_64 0:1.3.6-1.el6.remi.5.5.1 will be インストール
--> 依存性の処理をしています: /usr/bin/pecl のパッケージ
: php-pecl-jsonc-1.3.6-1.el6.remi.5.5.1.x86_64
--> 依存性の処理をしています: /usr/bin/pecl のパッケージ
: php-pecl-jsonc-1.3.6-1.el6.remi.5.5.1.x86_64
---> Package php-pecl-zip.x86_64 0:1.12.4-1.el6.remi.5.5 will be インストール
--> トランザクションの確認を実行しています。
---> Package php-pear.noarch 1:1.9.4-20.el6.remi will be インストール
--> 依存性解決を終了しました。

依存性を解決しました

========================================================================================
 パッケージ     アーキテクチャ   バージョン      リポジトリー             容量
========================================================================================
インストールしています:
 php-mysqlnd      x86_64     5.5.19-2.el6.remi   remi-php55            3.6 M
置き換えています  php-mysql.x86_64 5.3.3-40.el6_6
更新:
 php              x86_64       5.5.19-2.el6.remi   remi-php55             2.6 M
 php-cli          x86_64       5.5.19-2.el6.remi   remi-php55             3.7 M
 php-common       x86_64       5.5.19-2.el6.remi   remi-php55             1.0 M
 php-mbstring     x86_64       5.5.19-2.el6.remi   remi-php55             960 k
 php-mcrypt       x86_64       5.5.19-2.el6.remi   remi-php55              42 k
 php-pdo          x86_64       5.5.19-2.el6.remi   remi-php55             112 k
 php-process      x86_64       5.5.19-2.el6.remi   remi-php55              56 k
 php-xml          x86_64       5.5.19-2.el6.remi   remi-php55             208 k
依存性関連でのインストールをします。:
 php-pear         noarch       1:1.9.4-20.el6.remi remi-php55             371 k
 php-pecl-jsonc   x86_64       1.3.6-1.el6.remi.5.5.1 remi-php55           47 k
 php-pecl-zip     x86_64       1.12.4-1.el6.remi.5.5  remi-php55          269 k

トランザクションの要約
=======================================================================================
インストール         4 パッケージ
アップグレード       8 パッケージ

総ダウンロード容量: 13 M
これでいいですか? [y/N]y
パッケージをダウンロードしています:
(1/12): php-5.5.19-2.el6.remi.x86_64.rpm                  | 2.6 MB     00:00
(2/12): php-cli-5.5.19-2.el6.remi.x86_64.rpm              | 3.7 MB     00:00
(3/12): php-common-5.5.19-2.el6.remi.x86_64.rpm           | 1.0 MB     00:00
(4/12): php-mbstring-5.5.19-2.el6.remi.x86_64.rpm         | 960 kB     00:00
(5/12): php-mcrypt-5.5.19-2.el6.remi.x86_64.rpm           |  42 kB     00:00
(6/12): php-mysqlnd-5.5.19-2.el6.remi.x86_64.rpm          | 3.6 MB     00:00
(7/12): php-pdo-5.5.19-2.el6.remi.x86_64.rpm              | 112 kB     00:00
(8/12): php-pear-1.9.4-20.el6.remi.noarch.rpm             | 371 kB     00:00
(9/12): php-pecl-jsonc-1.3.6-1.el6.remi.5.5.1.x86_64.rpm  |  47 kB     00:00
(10/12): php-pecl-zip-1.12.4-1.el6.remi.5.5.x86_64.rpm    | 269 kB     00:00
(11/12): php-process-5.5.19-2.el6.remi.x86_64.rpm         |  56 kB     00:00
(12/12): php-xml-5.5.19-2.el6.remi.x86_64.rpm             | 208 kB     00:00
---------------------------------------------------------------------------------------
合計                                             5.4 MB/s |  13 MB     00:02
警告: rpmts_HdrFromFdno: ヘッダ V3 DSA/SHA1 Signature, key ID 00f97f56: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Importing GPG key 0x00F97F56:
 Userid : Remi Collet <RPMS@FamilleCollet.com>
 Package: remi-release-6.5-1.el6.remi.noarch (installed)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-remi
これでいいですか? [y/N]y
rpm_check_debug を実行しています
トランザクションのテストを実行しています
トランザクションのテストを成功しました
トランザクションを実行しています
  更新                    : php-process-5.5.19-2.el6.remi.x86_64  1/21
  更新                    : php-cli-5.5.19-2.el6.remi.x86_64      2/21
  更新                    : php-xml-5.5.19-2.el6.remi.x86_64      3/21
  インストールしています  : 1:php-pear-1.9.4-20.el6.remi.noarch   4/21
・
・
中略
・
・
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/wddx.so' - /usr/lib64/php/modules/wddx.so: undefined symbol: php_XML_Parse in Unknown on line 0
  インストールしています  : php-pecl-jsonc-1.3.6-1.el6.remi.5.5.1.x86_64                 7/21
・
・
中略
・
・
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/sqlite3.so' - /usr/lib64/php/modules/sqlite3.so: undefined symbol: php_checkuid in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/wddx.so' - /usr/lib64/php/modules/wddx.so: undefined symbol: php_XML_Parse in Unknown on line 0
  更新                    : php-pdo-5.5.19-2.el6.remi.x86_64            8/21
  インストールしています  : php-mysqlnd-5.5.19-2.el6.remi.x86_64        9/21
  更新                    : php-mcrypt-5.5.19-2.el6.remi.x86_64        10/21
warning: /etc/php.d/mcrypt.ini created as /etc/php.d/mcrypt.ini.rpmnew
  更新                    : php-mbstring-5.5.19-2.el6.remi.x86_64       11/21
  更新                    : php-5.5.19-2.el6.remi.x86_64                12/21
  削除中                  : php-mysql-5.3.3-40.el6_6.x86_64            13/21
  整理中                  : php-5.3.3-40.el6_6.x86_64                  14/21
  整理中                  : php-cli-5.3.3-40.el6_6.x86_64               15/21
  整理中                  : php-pdo-5.3.3-40.el6_6.x86_64               16/21
  整理中                  : php-xml-5.3.3-40.el6_6.x86_64               17/21
  整理中                  : php-process-5.3.3-40.el6_6.x86_64           18/21
  整理中                  : php-mbstring-5.3.3-40.el6_6.x86_64          19/21
  整理中                  : php-mcrypt-5.3.3-1.el6.rf.x86_64            20/21
  整理中                  : php-common-5.3.3-40.el6_6.x86_64            21/21
  Verifying               : php-pecl-zip-1.12.4-1.el6.remi.5.5.x86_64    1/21
  Verifying               : php-mcrypt-5.5.19-2.el6.remi.x86_64          2/21
  Verifying               : php-pecl-jsonc-1.3.6-1.el6.remi.5.5.1.x86_64 3/21
  Verifying               : 1:php-pear-1.9.4-20.el6.remi.noarch          4/21
  Verifying               : php-pdo-5.5.19-2.el6.remi.x86_64             5/21
  Verifying               : php-mbstring-5.5.19-2.el6.remi.x86_64        6/21
  Verifying               : php-process-5.5.19-2.el6.remi.x86_64         7/21
  Verifying               : php-cli-5.5.19-2.el6.remi.x86_64             8/21
  Verifying               : php-5.5.19-2.el6.remi.x86_64                 9/21
  Verifying               : php-common-5.5.19-2.el6.remi.x86_64         10/21
  Verifying               : php-mysqlnd-5.5.19-2.el6.remi.x86_64        11/21
  Verifying               : php-xml-5.5.19-2.el6.remi.x86_64            12/21
  Verifying               : php-pdo-5.3.3-40.el6_6.x86_64               13/21
  Verifying               : php-mbstring-5.3.3-40.el6_6.x86_64          14/21
  Verifying               : php-mysql-5.3.3-40.el6_6.x86_64             15/21
  Verifying               : php-xml-5.3.3-40.el6_6.x86_64               16/21
  Verifying               : php-cli-5.3.3-40.el6_6.x86_64               17/21
  Verifying               : php-5.3.3-40.el6_6.x86_64                   18/21
  Verifying               : php-mcrypt-5.3.3-1.el6.rf.x86_64            19/21
  Verifying               : php-process-5.3.3-40.el6_6.x86_64           20/21
  Verifying               : php-common-5.3.3-40.el6_6.x86_64            21/21

インストール:
  php-mysqlnd.x86_64 0:5.5.19-2.el6.remi

依存性関連をインストールしました:
  php-pear.noarch 1:1.9.4-20.el6.remi
  php-pecl-jsonc.x86_64 0:1.3.6-1.el6.remi.5.5.1 
  php-pecl-zip.x86_64 0:1.12.4-1.el6.remi.5.5

更新:
  php.x86_64 0:5.5.19-2.el6.remi
  php-cli.x86_64 0:5.5.19-2.el6.remi
  php-common.x86_64 0:5.5.19-2.el6.remi
  php-mbstring.x86_64 0:5.5.19-2.el6.remi
  php-mcrypt.x86_64 0:5.5.19-2.el6.remi
  php-pdo.x86_64 0:5.5.19-2.el6.remi
  php-process.x86_64 0:5.5.19-2.el6.remi   
  php-xml.x86_64 0:5.5.19-2.el6.remi

置換:
  php-mysql.x86_64 0:5.3.3-40.el6_6

完了しました!

なんかwarningがでましたがupdateは、完了したようです。

phpのバージョンを確認

[root@local ~]# php --version
PHP 5.5.19 (cli) (built: Nov 16 2014 09:53:48)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies

最新になりました。

しかし、以前にあったphp-gdモジュールがインストールされていないログがありました。
「パッケージ php-gd は利用できますが、インストールしませんでした。」

これを入れないと以前にあった記事と同じ状態です。
詳しくは、 先生、CentOS6にPHP-GDモジュールが入りません! を参照してください。

以前と同じコマンド

[root@local ~]#yum –enablerepo=remi-php55 -y install php-gd
読み込んだプラグイン:downloadonly, fastestmirror, priorities, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * extras: ftp.iij.ad.jp
 * remi-php55: remi.kazukioishi.net
 * updates: ftp.iij.ad.jp
58 packages excluded due to repository priority protections
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php-gd.x86_64 0:5.3.3-40.el6_6 will be インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-40.el6_6 のパッケージ: php-gd-5.3.3-40.el6_6.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: php-gd-5.3.3-40.el6_6.x86_64 (updates)
             要求: php-common(x86-64) = 5.3.3-40.el6_6
            インストール: php-common-5.5.19-2.el6.remi.x86_64 (@remi-php55)
                php-common(x86-64) = 5.5.19-2.el6.remi
            利用可能: php-common-5.3.3-38.el6.x86_64 (base)
                php-common(x86-64) = 5.3.3-38.el6
            利用可能: php-common-5.3.3-40.el6_6.x86_64 (updates)
                php-common(x86-64) = 5.3.3-40.el6_6
 問題を回避するために --skip-broken を用いることができません
 これらを試行できます: rpm -Va --nofiles --nodigest

エラーが出てできません。新しいものを入れるとまた新たな課題が・・・・・
あとは、mysqlのバージョンアップとPHP-GDモジュールです。

とりあえずは、mysqlのバージョンアップが先かな?
MySQL5.1をMySQL5.5にyumでアップデートするに続く

*****************************************************************************

応援をお願いします。

ブログランキング・にほんブログ村へ
にほんブログ村

スポンサーリンク